Advance Imaging – Adobe Photoshop CC

Introduction:
Adobe Photoshop CC 2018 is a popular image editing software that provides a work environment consistent with Adobe Illustrator, Adobe InDesign, Adobe Photoshop, and other products in the Adobe Creative Suite although Adobe Photoshop is a raster base graphic software.

What is Raster Graphics?
In computer graphics, a raster graphics or bitmap image is a dot matrix data structure that represents a generally rectangular grid of pixels (points of colour), viewable via a monitor, paper, or other display medium. Raster images are stored in image files with varying formats.

A bitmap is a rectangular grid of pixels, with each pixel's color being specified by a number of bits. A bitmap might be created for storage in the display’s video memory or as a device-independent bitmap file. A raster is technologically characterized by the width and height of the image in pixels and by the number of bits per pixel (or color depth, which determines the number of colors it can represent).

Introduction of Adobe Photoshop interface

Menu Bar
If you look at the top of the screen you will see the Menu bar, which contains all the main functions of Photoshop, such as File, Edit, Image, Layer, Type, Select, Filter, Analysis, 3D, View, Window, and Help.

Toolbar
Most of the major tools are located in the Toolbar for easy access.

The Image
The image will appear in its own window once you open a file.

Image Name
The name of any image that you open will be at the top of the image window as shown above.
**Palettes**

Palettes contain functions that help you monitor and modify images. By default, palettes are stacked together in groups. These are the palettes that are usually visible: Color, Adjustments and Layers. If none of the palettes are visible, go to Window in the Menu bar and choose the palettes you need.

**Color, Swatches, Style**

The Color palette displays the current foreground and background colors and RGB values for these colors. You can use the sliders to change the foreground and background colors in different color modes. You can also choose a color from the spectrum of colors displayed in the color ramp at the bottom of the palette.

In the Swatches palette you can choose a foreground or background color and add a customized color to the library.

The Styles palette allows you to view, select, and apply preset layer styles. By default, a preset style replaces the current layer style. You can use the styles in the palette or add your own using the Create New Style icon.

**Understanding of resolution, color depth and color mode.**

**Resolution**

PPI & DPI Pixel per inch and Dots per inch the standard unit for measuring the image size. Resolution is the number of pixels on a printed area of an image. The higher the resolution, the more pixels there are on the page, the better the quality of the image. However, high resolution increases the size of the file. The standard recommended resolution for printed images is 150-300 dpi, for Web images it is 72 dpi.

**Color Mode**

Choose a color mode that will best fit your project. For example, when making a graphic for a web site, choose RGB. When making an image for print choose CMYK.

**Resizing to a Specific Size, Enlarging, and Compressing.**

To resize your image to different size:
1. In the main menu, go to Image > Image Size.
2. In the Image Size dialog box, you can readjust your image by typing in the width and height that is needed for your resizing. An important reminder is that if your document is not already 300ppi or a high resolution photo, making your image drastically larger than what it already is can distort the document, thus the same for making a large document smaller. Photoshop measures in pixels, so...
altering sizes of a photo can reduce the quality. It is best to adjust size first before doing any editing.

1. Under Dimensions, you can see your original document size. If you use the drop down arrow, you can see different units of measurements for your document. Use the original size to determine the proportions for your resizing.
2. Adjust your new height and width by typing in the desired new proportions.
3. Type in your desired resolution
4. (150-300 PPI for high quality prints, and 72 PPI is good for web images).
5. Have the Resample checked to tell Photoshop to try and keep your pixels together if you’re making a drastic change.
6. Click Ok.
7. Your document should be now of the desired proportions, if you are dissatisfied, you can hold Ctrl+Z to undo the sizing adjustment, or you can use the crop tool to get the desired look.

**Color Adjustment**

Color adjustment options in Photoshop CC 2018 can help you to make your digital photos look more natural. To color correct your images, follow these steps:

1. Open the image you wish to correct.
2. In the main menu, go to Image > Adjustments > Levels. You will see a dialog box displaying a diagram of the colors in your image (Figure 30). The black triangle is for shadows, the gray is for midtones, the white is for highlights. In the Channels dropdown menu, you can choose between RGB. These indicate whether your changes affect all the colors, or just one (red, green, or blue).

![Levels window](Image)

![Underexposed photo](Image)

3. Make sure the Preview box is checked off. Choose the channel you wish to change and drag the triangles. Dragging the black triangle to the right will make the shadows in your photo darker.

   Dragging the white triangle to the left will make the highlights in your photo lighter. Dragging the gray triangle to the left will make the midtones in your photo lighter, and dragging it to the right will make the midtones darker. You will be able to see the changes in your image. (Underexposed photo) shows a photo which is underexposed. By correcting the highlights and making the image lighter, we are able to make the photo appear much brighter (Corrected photo).
Selection Tools:

**Move:**
Used to select and move objects on the page. Click the tool button, then click on any object on the page you wish to move.

**Marquee:**
Selects an object by drawing a rectangle or an ellipse around it. Click the tool button, choose a rectangular or an elliptical marquee. Drag the marquee over the area of the image you wish to select.

**Lasso:**
Selects an object by drawing a freehand border around it. Click the tool button, drag to draw a freehand border around the area of the image you wish to select.

**Magic Wand:**
Selects all objects in a document with the same or similar fill color, stroke weight, stroke color, opacity or blending mode. By specifying the color range or tolerance, you can control what the Magic Wand tool selects.

Transformation Tool:
Best way to transform your object is that after selecting the area of your image which you want to transform you have to press Ctrl+T to enable the transformation tool on the selection and you will see the regular transformation tool around your object like we see in other
Understanding of layers and its working:

Layers:
Layers let you organize your work into distinct levels that can be edited and viewed as individual units. Every Photoshop CC document contains at least one layer. Creating multiple layers lets you easily control how your artwork is printed, displayed, and edited. You will use the Layers palette often while creating a document, so it is crucial to understand what it does and how to use it.

1. Layer Visibility - The eye shows that the selected layer is visible. Click on or off to see or to hide a layer.
2. Layer Locking Options - Click the checkered square icon to lock Transparency, click the brush icon to lock the Image, click the arrow icon to lock the Position, and click the lock icon to lock all options.
3. Layer Blending Mode - Defines how the layer’s pixels blend with underlying pixels in the image. By choosing a particular blending mode from the drop-down menu you can create a variety of special effects.
4. Fill - By typing in a value or dragging the slider you can specify the transparency.
5. Opacity - By typing in a value or dragging the slider, you can specify the transparency of the entire layer.
6. Layer Mask - Allows you to hide certain parts of the layer, which can then be revealed by using the paintbrush and the white paint color to expose portions of the layer.
7. Create New Fill or Adjustment Layer - Have the same opacity and blending mode options as image layers and can be rearranged, deleted, hidden and duplicated in the same manner as image layers. Click the icon and select an option to create a new fill or adjustment layer.
8. Create New Layer - Click this icon to create a new layer.
9. Layer Lock - The icon shows when the layer is locked and disappears when it is unlocked. Double-click the icon to unlock the layer.
10. Link Layers – Can be used to link layers together.
11. Layer Styles - If a layer has a style, an “F” icon shows at the bottom of the Layers palette. Click the little black triangle to see style options.

Image Adjustments and Enhancements:

Filters and Effects:
A can be applied to the active layer, or to a Smart Object. Filters applied to a Smart Object are nondestructive and can be readjusted at any time. Do one of the following:

- To apply a filter to an entire layer, make sure the layer is active or selected.
- To apply a filter to an area of a layer, select that area.
- To apply a filter nondestructively so you can change your filter settings later, select the Smart Object that contains the image content you want to filter.

Filter Gallery:

The Filter Gallery provides a preview of many of the special effects filters. Multiple filters can be apply/use on the same object/image, turn on or off the effect of a filter, reset options for a filter, and change the order in which filters are applied. When you are satisfied with the preview, you can then apply it to your image. Press Ctrl+F to open the filter gallery.

A. Preview B. Filter category C. Thumbnail of selected filter D. Show/Hide filter thumbnails E. Filters pop-up menu F. Options for selected filter G. List of filter effects to apply or arrange H. Filter effect selected but not applied I. Filter effects applied cumulatively but not selected J. Hidden filter effect
ply a gradient fill:

The Gradient tool creates a gradual blend between multiple colors. You can choose from preset gradient fills or create your own. Gradient tool cannot be use with the bitmap or indexed-color images.

1. To fill part of the image, select the desired area. Otherwise, the gradient fill is applied to the entire active layer.
2. Select the Gradient tool □. (If the tool isn’t visible, hold down the Paint Bucket tool.)
3. In the options bar, choose a fill from the wide gradient sample.
4. Select an option to determine how the starting point (where the mouse is pressed) and ending point (where the mouse is released) affect gradient appearance.

**Linear Gradient** Shades from the starting point to the ending point in a straight line.

**Radial Gradient** Shades from the starting point to the ending point in a circular pattern.

**Angular Gradient** Shades in a counterclockwise sweep around the starting point.

**Reflected Gradient** Mirrors the same linear gradient on either side of the starting point.

**Diamond Gradient** Shades from the middle to the outer corners of a diamond pattern.
Border, shadow, bevel & emboss:
In Photoshop all layers can be individually customizable in various aspects, for Layer Style option double click on the layer from the layer panel:
A. Layer effects icon
B. Click to expand and show layer effects
C. Layer effects

Layer styles use to apply effects, such as color overlays, drop shadows, glow, or bevel & emboss, to the primary layer. To create a rollover pair, turn the layer style on or off and save the image in each state.

Drop Shadow:
Adds a shadow that falls behind the contents on the layer.

Outer Glow and Inner Glow:
Add glows that emanate from the outside or inside edges of the layer’s content.

Bevel and Emboss:
Add various combinations of highlights and shadows to a layer.

Color, Gradient, and Pattern Overlay
Fills the layer’s content with a color, gradient, or pattern.

Stroke as Borders
Outlines the object on the current layer using color, a gradient, or a pattern. It is particularly useful on hard-edged shapes such as type.
Scale & Rotate:
The Free Transform command lets you apply transformations (rotate, scale, skew, distort, and perspective) in one continuous operation. You can also apply a warp transformation. Instead of choosing different commands, you simply hold down a key on your keyboard to switch between transformation types.

1. Select what you want to transform.
2. Open Edit Menu > Free Transform (Short Key Ctrl+T).
3. To scale by dragging, drag a handle.
   Press Shift as you drag a corner handle to scale proportionately.
4. To rotate by dragging, move the pointer outside the bounding border (it becomes a curved, two-sided arrow), and then drag. Press Shift to constrain the rotation to 15° increments.

Layer opacity and blending:

Layer Opacity
A layer’s overall opacity determines to what degree it obscures or reveals the layer beneath it. A layer with 1% opacity appears nearly transparent, whereas one with 100% opacity appears completely opaque.
In addition to overall opacity, which affects layer styles and blending modes applied to a layer, you can specify fill opacity. Fill opacity affects only pixels, shapes, or text on a layer without affecting the opacity of layer effects such as drop shadows.

1. In the Layers panel, select one or more layers or groups.
2. Change the Opacity and Fill values. (If you selected a group, only Opacity is available.)

Layer Blending:
By default, the blending mode of a layer is Pass Through, which means that the layer has no blending properties of its own. When you choose a different blending mode for a layer, you effectively change the order in which the image components are put together. Choose a blending mode other than Pass Through for the layer.

More Blending mode examples:
These examples show the result of painting part of the image’s face using each blending mode.
**Hue and saturation:**
The Hue/Saturation command adjusts the hue (color), saturation (purity), and lightness of the entire image or of individual color components in an image. Use the Hue slider to add special effects, to color a black and white image (like a sepia effect), or to change the range of colors in a portion of an image. This adjustment is especially good for fine-tuning colors in a CMYK image.

1. Image Menu > Adjustment > Hue/Saturation. (Short key Ctrl+U)
2. Choose Master to adjust all colors at once. OR Choose one of the other preset color ranges listed for the color you want to adjust. To modify the color range.

Changing colors in an image using the Hue/Saturation command

A. Original B. Entire image changed to sepia using the Colorize option C. Magenta colors targeted in the Edit menu and changed using the Hue slider

**Perspective Crop Tool:**
A much easier and faster way to correct images that suffer only from perspective distortion is to use the Perspective Crop Tool.

1. In this case, we will be extracting the painting from the wall.
2. Select the Perspective Crop Tool from the Tools panel.
3. Click and drag to create a rectangle that covers your whole image.
4. Drag the corner handles so that the horizontal and vertical lines of the grid align with the respective lines of your subject.
5. Press Enter to crop.

**Use of retouch tools:**

**Retouch with the Healing Brush tool:** The Healing Brush tool lets you correct imperfections, causing them to disappear into the surrounding image. Like the cloning tools, you use the Healing Brush tool to paint with sampled pixels from an image or pattern. However, the Healing Brush tool also matches the texture, lighting, transparency, and shading of the sampled pixels to the pixels being healed. As a result, the repaired pixels blend seamlessly into the rest of the image.

1. In this example using the healing tool we will remove the bird.
2. Select the Healing Brush tool
3. Specify the source for repairing pixels by holding the Alt key and left click and release the Alt key.
4. Use the Healing brush on the effected are i.e. bird, healing tool will use the pixels from the source and adjust on the destination.
Retouch with the Clone Stamp tool: The Clone Stamp tool paints one part of an image over another part of the same image or over another part of any open document that has the same color mode. You can also paint part of one layer over another layer. The Clone Stamp tool is useful for duplicating objects or removing a defect in an image.
1. In this example using the Clone Stamp tool we will add another hot air balloon.
2. Select the Clone Stamp tool.
3. Specify the source for copying the pixels by holding the Alt key and left click and release the Alt key.
4. Use the Clone Stamp tool on similar place where you want to paste the hot air balloon.
Clone Stamp tool will use the pixels from the source and paste it on the destination.

**Saving images for web and print media.**

Saving image for Print Media:
Originally when we are working in Photoshop with layers and objects Photoshop saves the document in PSD format whereas if need to save the picture for print media it is recommended to save images in JPEG format with the resolution up to 200 to 300 DPI, saving image at this resolution avoids pixilation at later stage. To save image in Photoshop follow these steps:
1. Click on File Menu.
2. Click Save As (Short Key Ctrl+Shift+S).
3. Type the name for the picture.
4. Select a file format for your image.
5. Click save button.

Saving image for Web:
While saving pictures for web we have to be careful about the size of the file as on web we always keen to keep the file size smaller, this helps the website to load quickly as all the content on webpage downloaded on your computer via internet. Therefore, it is highly recommended to save the files which we are intended to save for webpages should be in smaller size and the recommended format is GIF, PNG and JPEG.
1. Click on File Menu.
2. Click Save for Web (Short Key Ctrl+Alt+Shift+S).
3. Select fit on screen to check the overall look of the image.
4. Select appropriate file format.
5. Set appropriate quality.
6. Check the estimated file size to meet the desired requirement.
7. Click save button to save the file.