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Modular Designing –  Reinforcement Handout 

 

What is MS Visio? 

Microsoft Visio is a diagramming tool that allows you to create diagrams (ranging from simple to 
complex), which aid in data visualization and process modelling. Visio also helps to create detailed 
org charts, floor plans, pivot diagrams, etc. Microsoft Visio is one of the most popular diagramming 
software that empowers diagramming, data visualization, and process modelling in a familiar 
interface.   
 
Visio User Interface: 

The user interface of Visio is similar to that of other programs in the Office suite. You will be greeted 
with a Start page that lists some of the recent documents you have opened along with featured 
templates for creating common diagram types. 
You can also search for templates on the Microsoft website right from the Start screen. 
 

 
 
The top right corner shows the Microsoft account you are connected to, if you are an Office 365 
subscriber. Apart from the featured templates, you can also click Templates to browse through the 
template categories. 
 
 
Document Interface: 
 
Clicking any of the above templates opens the template document 
 
The document interface of Visio is similar to other Office programs such as Word or Excel. On the 
top, you have the Quick Access toolbar, which contains common commands, such as Save, Undo, 
and Redo. This can be customized as needed. 
 
Below the Quick Access toolbar is the familiar Office Ribbon. The Home tab lists common commands 
for working with the document. We will learn more about other tabs as we go along. 
 
On the left-hand pane, there is Shapes, which lists the common shapes that go well with the 
template. To insert a shape, just click and drag the shape onto the canvas. There are many shapes 
available in Visio and we will get more familiar with them as we move ahead. 
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When you place shapes onto the canvas, you will see guides that help you align the shapes with 
respect to the objects already on the canvas. You also have a ruler on the top and left of the canvas. 
This gives a sense of perspective and lets you create perfectly aligned diagrams. 
 
Shapes in Visio are basically vector graphics and as such you can enlarge or shrink the size as needed 
without loss of quality. You also get an idea of the relative dimensions of all the other shapes 
(indicated by green arrows) when you try to change the dimensions of any shape. 
 
 
Creating and Arranging SmartShapes: 
 
SmartShapes provide contextual shapes which relate to the 
selected shape. SmartShapes are connected to the original shape 
and the connector also moves whenever the SmartShape is 
moved. 
 
Creating a SmartShape: 
 
Start with a blank document (in this case a flowchart diagram). You 
will notice that the Shapes pane has different shapes that are 
applicable to flowcharts. Click and drag a shape onto the empty 
canvas. You can resize or rotate the shape as desired. You can even 
align the shape with the help of the alignment guides. 
 
When you drag a shape onto the canvas, you will notice that there 
are four arrows along the shape. Hovering over any of these 
arrows will show possible shapes that can be created and linked to 
this shape. 
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Click the desired shape to create the shape. You will also notice that the shape is automatically 
connected to the initial shape. If you were to drag the shape manually, you will need to connect it 
manually as well. The connections between the shapes are dynamic and they will move in relation to 
the placement of the shape. 
 
 
Arranging SmartShapes: 
 
The SmartShape arrow lists the first four shapes for the diagram that are seen in the Shapes pane. 
You might want to customize which shapes appear in the four SmartShape options depending on 
your workflow.  
 
To set the shapes that you prefer as SmartShapes, first select the desired shape in the Shapes pane 
and drag it to one of the first four shapes within the pane. 
In this example, let us assume that the Database shape needs to be 
in the first four. Click and drag the Database shape into one of the 
first four positions. 
 
Now, when you create a SmartShape, you will find that the Database 
shape is made available. 
 

 
 
Connecting SmartShapes 
 
SmartShapes allows to automatically connect shapes. If you want to connect shapes that are not 
directly related, you can manually connect them. 
 
To manually connect shapes, click the Connector tool in the Tools section of the Home tab. The 
mouse pointer now changes into a connector. 
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Draw a connecting line from the originating shape to the 
destination. You will notice a dotted line representing the 
connector. You can either glue this connector to the connection 
point or glue it to the destination shape. Gluing it to the shape 
will enable you to move the shape to a different location on the 
canvas along with the connector. 
 
Click the Pointer Tool in the Tools section of the Home tab to 
return the mouse pointer back to normal. 

 

 

 

 

 
Connected SmartShapes: 
 
Newer versions of Visio have built-in intelligence to help you place shapes between other shapes. 
Visio automatically adds the required spacing and connectors to ensure that the new shape is 
inserted in the correct position. 
 
To insert a shape between two shapes, drag the new shape in between the desired shapes, till you 
see green squares on the connectors and release the mouse. The new shape will be inserted with 
equal spacing and appropriate connections. 
 
If you delete the inserted shape, the connector extends all the way till the next shape. 
 
 
Align and Space Shapes: 
 
To automatically align and space shapes in a diagram, go to the Position dropdown menu in the 
Arrange section of the Home tab. Click either Auto Space or Auto Align & Space depending on the 
requirement. You can also hover the mouse on these commands to preview how the diagram would 
look after alignment. 

 
 
After alignment, you can still move the shapes in your diagram, if you would like a more customized 
appearance. 
 
 
Changing the Diagram Layout: 
 
Visio provides options for automatically changing the layout of the diagram with the ReLayout Page 
command. The Re-Layout Page command provides commonly used layouts. You can also customize 
some of the aspects of the layout as needed. 
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Open the diagram and navigate to the Design tab on the Ribbon. Click the Re-Layout Page dropdown 
menu and select a layout as needed. You will see that the diagram now changes to the selected 
layout. You can also preview the look before clicking by hovering the mouse over the layout style. 
 

 
 

Inserting Text in a Shape: 
 
It is easy to insert text within a shape. Just double-click within a shape to type the text. The text 
automatically wraps according to the shape, however, you can also press hard returns if you would 
like to have your own wrapping. Notice that Visio automatically zooms into the shape to enable 
typing and zooms out when you click outside the shape. 

 
 

 

Inserting Text in a Document: 
 
To insert a text in a document such as a heading for the chart, click the Text Box dropdown menu in 
the Insert tab on the Ribbon and select either horizontal or vertical text box. 
 

 
 

Then place the cursor on the document and draw a text box to start typing. 
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Inserting a Background Page: 
 
You can change the background of a document by choosing from preset backgrounds or using your 
own background template. To insert a background, click the Background dropdown menu from the 
Design tab on the Ribbon and choose a background preset. 
 
This creates a new page in addition to the diagram page. You can right-click the newly created 
background page to rename it. The new background will be automatically applied to all newly 
created pages in the document. 

 
 

 
Shape Formatting: 
 
You can also format the shapes to give them a more professional or casual look as desired. To format 
shapes, select the shape in the diagram and format using the options available in the Shape Styles 
section. 
 

 
 
You can select predefined shape styles or you can customize the shape using the Fill dropdown 
menu. To adjust the color of the shape border, select a color from the Line dropdown menu. The 
Effects menu allows to add special effects to your shape such as drop shadows or 3D rotations. 
 

Text Formatting: 

If you are familiar with Microsoft Word, you should be right at home in Visio with respect to 
formatting text. You can format titles and text within shapes. You can also use the Format Painter 
command to copy formatting and paste it into another shape or text box. 
 
To format the text, select the text box containing the text or highlight the text itself. Then, choose 
from the options available in the Font and Paragraph sections of the Home tab. 
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You can change the font, size, color, and paragraph alignment. If you want to change the font styles 
in a shape, just double-click the shape to select the text within the shape and change the font styles 
as desired. 
 

Visio Themes and Styles: 

Themes apply to the entire diagram. Themes comprise of a set of colors and effects that generally 
blend well with each other. They are a great way to quickly give the diagram a polished look. Themes 
also affect other parts of the document such as titles, headings, text, etc. 
 
To apply a theme, go to the Design tab and select a theme from the Themes section. The dropdown 
arrow provides more choices categorized by theme type. When you click a theme, all the aspects of 
the diagram and other parts of the document reflect the theme settings. 
 

 
 
A theme can have many variants, which can be selected from the Variants section of the Design tab. 
 
Styles are different from themes such that, they are applicable to a selected shape or a group of 
shapes. Styles help in customizing the aspects of a particular style. 
 
To change a style of a shape, select the shape and from the Home tab, then select a style from the 
Shape Styles section. Style can be applied to both shape elements in the diagram as well as to 
individual text boxes. You can select multiple shapes to apply the style to all of them together. 
 

 
 

When you change a theme after applying a style to a shape, the shape will take up the 

characteristics of the theme but will still remain distinct from other shapes.  
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Applying Theme Colors and Effects: 

Themes are useful to customize the appearance of the document. Visio goes a step further and 
allows to customize the themes themselves. 
 
Themes come with variants that can be further customized as needed. Theme variants can be 
accessed from the Variants section in the Design tab. You can use the stock variants or click the 
dropdown menu to customize many other aspects. 
 
In the Colors menu, you will find that there many color combinations to choose from. 
 

 

The Effects menu shows some of the effects that can be applied onto the selected shape. 
 

 

You can also choose from a range of connectors. 
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Rulers and Guides: 

Visio comes with visual aids to help align and structure the elements in the diagram so that it 
appears great both on-screen and in print. The main visual aids available include rulers, grids, and 
guides. 
 

Rulers: 

Rulers help in providing perspective to the elements in the diagram. They help orient the shapes to 
attain a consistent and clean look. Rulers can be switched off or on with a simple checkbox in the 
Show section of the View tab. 
 

 

When you move a shape, you will notice that there are 3 dotted lines (shown in the following 
example in red rectangles) on both the vertical and horizontal rulers. These 3 dotted lines denote 
the left, middle, and right parts of the diagram. When you drag the shape vertically or horizontally, 
these 3 dotted lines help position the shape exactly at the place you need. 
 

 

You can turn of the Ruler checkbox if you need some screen estate. 
 
Guides: 

Just like rulers, guides help in orienting different shapes of the diagram properly. You can create any 
number of guides from both the vertical and horizontal rulers. To create a guide, simply drag a line 
from either the vertical or horizontal rulers. 
 

 



Reinforcement Handout: Modular Designing   Class 6 – Term-2 

The City School /Academics/Computing Curriculum/Class 6 /2019-2020                                                                    Page 10 of 10 

Guides are represented by lines, which appear thick when selected. You can delete a guide by simply 
selecting the guide and pressing the Delete key on the keyboard. Uncheck the Guides checkbox in 
the View tab to remove all the guides from view. 
 
Dragging a shape onto a guide will enable you to snap the shape to the guide. When a shape is 
snapped to a guide, it moves along with the guide. 
 

 
 

Printing Diagrams: 

To print a drawing, simply go to the File menu and click Print or press the keyboard shortcut Ctrl+P. 
The Print menu provides several options to select the layout of the printed page and the printer to 
which you’d like to send the document for printing. 
 

 

The right side of the Print menu shows a preview of the output. You can change the orientation of 
the page, page size, and select only the pages that you need to print. 
 
Depending on your printer, you can also print in color or in greyscale. Remember that printing in 
black and white might not produce a good output. It is best to print in greyscale, if you wish to save 
on your printer’s ink. 


